Szerző Téma: [MTA] Villogó  (Megtekintve 2934 alkalommal)

Nem elérhető Woide

[MTA] Villogó
« Dátum: 2019. Augusztus 02. - 19:40:34 »
0 Show voters
[MTA] Villogó
Sziasztok!
 
Van egy villogó script, ami rátesz egy objectet a kocsira, ami villog. Ez a script a Freedom Gaming modjából van, viszont én ezt fun szerveren szeretném alkalmazni. Egyébként ugyan ez van SeeMTA-n is amikor pl a TEK-esek rakják fel a villogót a BMW M5-re. Visszatérve a tárgyra, minden jó felrakja az autóra, ha akarod le is veszi, ott is marad rajta fixen, de nem villog. A scriptbe bele van írva, ha felkerül akkor villogjon, de valamiért nem villog.
 

function felrakVillogo(p,c,state, vehicle)
if isPedInVehicle(p) then
   local veh = getPedOccupiedVehicle(p)
   setElementData(getPedOccupiedVehicle(p),\"villogo\",state)
   setVehicleSirensOn(veh, true)
end
end
addCommandHandler(\"villogofelrak\", felrakVillogo)

 
Ezen kívül még van több része is, de nem hinném, hogy ott lenne a baj, mivel felrakja, csak nem villog.
 
Itt van róla egy videó: Videó a villogóról
 
Előre is köszönöm a segítséget!

[MTA] Villogó
« Válasz #1 Dátum: 2019. Augusztus 02. - 19:58:36 »
+1 Show voters

 

setVehicleSirensOn

 
csak akkor működik, ha a járművön van alap gta-s villogó, pl a rendőrautók.  
 

addVehicleSirens()

 
Ilyened van a kódodban?

Nem elérhető Woide

[MTA] Villogó
« Válasz #2 Dátum: 2019. Augusztus 02. - 20:07:12 »
0 Show voters
Másoknak működik roleplay szervereken, csak ők item rendszerbe oldják meg, hogy onnan lehessen felrakni, bármilyen autóra. Én is roleplay modból vettem ki, és próbálom átemelni fun szerverre. Szóval ugyan az mint roleplay szervereken, csak nem szeretném item rendszerből működtetni.
 
addVehicleSirens-el próbálkoztam már, de csak hangot adott, villogni nem villogott.

[MTA] Villogó
« Válasz #3 Dátum: 2019. Augusztus 02. - 20:14:10 »
+1 Show voters
Mert ez is kell hozzá.
 

setVehicleSirens()

 
 

Nem elérhető Woide

[MTA] Villogó
« Válasz #4 Dátum: 2019. Augusztus 02. - 20:22:49 »
0 Show voters
setVehicleSirens-el sem villog, csak szirénázik. Próbáltam egy community-s scriptet, ami adott villogót, viszont hangot nem, megpróbáltam ötvözni a kettőt, akkor egyik sem működött.
« Utoljára szerkesztve: 2019. Augusztus 02. - 20:25:37 írta Woide »

Nem elérhető Woide

[MTA] Villogó
« Válasz #5 Dátum: 2019. Augusztus 02. - 21:09:00 »
0 Show voters
Sikerült, működik. Viszont az engedélyezett autókban, ha nincs fent a villogó object akkor is megy a sziréna. Hogyan csináljam meg, hogy csak akkor lehessen beindítani a sziréna hangot és a villogást, ha fent van a villogó object?
 
 
« Utoljára szerkesztve: 2019. Augusztus 02. - 21:48:20 írta Woide »

Nem elérhető Fuzzy

[MTA] Villogó
« Válasz #6 Dátum: 2019. Augusztus 03. - 08:16:37 »
0 Show voters
Wikipédiát szoktál nézni? Mert ezekre a kérdésekre magadtól is tudnál választ kapni. Egyébként mikor leveszed a villogót: removeVehicleSirens(kocsiElement)

[MTA] Villogó
« Válasz #7 Dátum: 2019. Augusztus 03. - 17:48:32 »
+1 Show voters
Idézetet írta: Woide date=1564772940


   
      Sikerült, működik. Viszont az engedélyezett autókban, ha nincs fent a villogó object akkor is megy a sziréna. Hogyan csináljam meg, hogy csak akkor lehessen beindítani a sziréna hangot és a villogást, ha fent van a villogó object?
   
   
       
   


Mivel adsz nekik elementDatát, itt
 

setElementData(getPedOccupiedVehicle(p),\"villogo\",state)

 
így simán csak lekérdezed, hogy a kocsin van-e villogó, és ha van, akkor fusson le a funkció, ami adja a villogást, és a hangot.
 
 

Nem elérhető Woide

[MTA] Villogó
« Válasz #8 Dátum: 2019. Augusztus 03. - 19:52:34 »
+1 Show voters
Idézetet írta: BlackSy date=1564847312


   
      Mivel adsz nekik elementDatát, itt
   
   

setElementData(getPedOccupiedVehicle(p),\"villogo\",state)

   
      így simán csak lekérdezed, hogy a kocsin van-e villogó, és ha van, akkor fusson le a funkció, ami adja a villogást, és a hangot.
   
   
       
   


Tökéletes lett, köszönöm szépen a segítséget!

Re:[MTA] Villogó
« Válasz #9 Dátum: 2023. Február 05. - 13:08:48 »
0 Show voters
Valaki elkűldené nekem a scriptet?

 

SimplePortal 2.3.7 © 2008-2024, SimplePortal